Função SE com mais de sete condições!

Padrão

Todos os que usam o Excel há um certo tempo, já se depararam com a função SE, e algum dia já precisaram construí-la com mais de 7 condições, vejamos neste exemplo como podemos fazer isto.

Vamos supor que você queira que ela analise uma célula que tem nomes de meses e retorne seus respectivos números de ordem, mas os meses do ano são 12 e a SE oferece análise para 7 condições somente, e agora?

No exemplo a SE vai analisar o que estiver na célula “i1″.

Na célula que você quer o resultado você digita a fórmula abaixo:

=SE(I$1=”JANEIRO”;1;SE(I$1=”FEVEREIRO”;2;SE(I$1=”MARÇO”;3;SE(I$1=”ABRIL”;4;SE(I$1=”MAIO”;5;SE(I$1=”JUNHO”;6;SE(I$1=”JULHO”;7)))))))

Em outra célula qualquer, que como exemplo usaremos a “iv1″, digite a fórmula abaixo

=SE(I$1=”AGOSTO”;8;SE(I$1=”SETEMBRO”;9;SE($1=”OUTUBRO”;10;SE(I$1=”NOVEMBRO”;11;SE(I$1=”DEZEMBRO”;12)))))

Aí você volta à primeira fórmula digitada e acrescenta “$iv$1″ no final, como está abaixo.

=SE(I$1=”JANEIRO”;1;SE(I$1=”FEVEREIRO”;2;SE(I$1=”MARÇO”;3;SE(I$1=”ABRIL”;4;SE(I$1=”MAIO”;5;SE(I$1=”JUNHO”;6;SE(I$1=”JULHO”;7;$iv$1)))))))

Com isso podemos entender que podemos colocar quantas condições forem necessárias.

Abraços.

Caso você tenha uma dica ou truque, envie para nós: contato@dicasdeexcel.com.br

Contribuição de: Leandro A. R. Barbosa

17 Comments

  1. o que eu posso dizer? Meus parabéns por este artigo, resolveu o problema q eu estava há 4 horas tentando solucionar, li vários artigos, mas este q resolveu meu problema.

    valeu!!!!!!!!!!

  2. Estão de parabéns pelo site.
    Vocês são práticos e realistas.
    Parabéns a todos!

  3. parabéns!! estava ha horas tentando achar uma solução!!!

  4. Uma outra forma é usar função se encadeada, onde cada condição será o valor falso da outra condição
    Ex: Se A1 for entre 100 e 50 B1 será “C”, se for entre menor que 49 será “B”, se for igual a 0 será “A”.
    =SE(A1=0;”A”;SE(A1<50;”B”;SE(A1<100;”C”;””)))

  5. fiz como seu exemplo mas não consegui que uma “puxasse” os dados da outra só aparece as condições da primeira o que posso ter feito de errado?

  6. Este site é muito bom! Por favor, quem puder, colcabore com as sugestões. Eu sou um aprendiz e só posso me contemplar pela existência dele. Obrigado!

  7. Olá Amigos,

    O trabalho de voçes está muito bom, parabéns a todos.

    Gilvan Sousa

  8. Kra valeu mesmo a dias eu andava atrás desta função, obrigado!

  9. Valeu pessoal, vcs me ajudaram muito.
    Estava a +/- 3:00 procurando esta fórmula.
    Este site realmente foi muito útil.
    Obrigado

Comments are closed.